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5 QUICK FIXES 

Lesson overview 
In this lesson, you’ll learn how to do the following: 

• Remove red eye. 

• Brighten an image. 

• Adjust the features of a face. 

• Combine images to create a panorama. 

• Crop and straighten an image and fill in any resulting empty areas. 

• Blur the background of an image using Iris Blur. 

• Merge two images to extend depth of field. 

• Apply optical lens correction to a distorted image. 

• Move an object seamlessly. 

• Adjust the perspective of an image to match another image. 
 

This lesson will take about an hour to complete. Please log in to your 
account on peachpit.com to download the lesson files for this chapter, or 
go to the Getting Started section at the beginning of this book and follow 
the instructions under “Accessing the Lesson Files and Web Edition.” 
As you work on this lesson, you’ll preserve the start files. If you need to 
restore the start files, download them from your Account page. 
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Sometimes just one or two clicks in Photoshop can 
turn an image from so-so (or worse) to awesome. 
Quick fixes get you the results you want without a lot 
of fuss. 
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● Note: If you haven’t 
installed Bridge, you’ll 
be prompted to do 
so when you choose 
Browse In Bridge. For 
more information, see 
page 3. 

 
● Note: If Bridge 
asks you if you want 
to import preferences 
from a previous version 
of Bridge, click No. 

Getting started 
Not every image requires a complicated makeover using advanced features in 
Photoshop. In fact, once you’re familiar with Photoshop, you can often improve an 
image quickly. The trick is to know what’s possible and how to find what you need. 

In this lesson, you’ll make quick fixes to several images using a variety of tools 
and techniques. You can use these techniques individually, or team them up when 
you’re working with an image that needs just a little more help. 

1 Start Photoshop, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (Mac) to restore the default preferences. (See 
“Restoring Default Preferences” on page 5.) 

2 When prompted, click Yes to delete the Adobe Photoshop Settings file. 

 
Improving a snapshot 
If you’re sharing a snapshot with family and friends, you may not need it to look 
professional. But you probably don’t want glowing eyes, and it would be good if the 
picture isn’t too dark to show important detail. Photoshop gives you the tools to 
make quick changes to a snapshot. 

Correcting red eye 
Red eye occurs when the retina of a subject’s eye is reflected by the camera flash. It 
commonly occurs in photographs taken in a dark room, because the subject’s irises 
are wide open. Fortunately, red eye is easy to fix in Photoshop. In this exercise, you 
will remove the red eye from the woman’s eyes in the portrait. 

You’ll start by viewing the before and after images in Adobe   Bridge. 

1 Choose File > Browse In Bridge to open Adobe Bridge. 

2 In the Favorites panel in Bridge, click the Lessons folder. Then, in the Content 
panel, double-click the Lesson05 folder to open it. 

3 Adjust the thumbnail slider, if necessary, so that you can see the thumbnail 
previews clearly. Then look at the RedEye_Start.jpg and RedEye_End.psd files. 
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RedEye_Start.jpg RedEye_End.psd 

Not only does red eye make an ordinary person or animal appear sinister, but it can 
distract from the subject of the image. It’s easy to correct red eye in Photoshop, and 
you’ll quickly lighten this image too. 

4 Double-click the RedEye_Start.jpg file to open it in Photoshop. 

5 Choose File > Save As, choose Photoshop for the Format, name the file RedEye_ 
Working.psd, and click Save. 

6 Select the Zoom tool ( ), and then drag to zoom in to see the woman’s eyes. If 
Scrubby Zoom isn’t selected, drag a marquee around the eyes to zoom in. 

7 Select the Red Eye tool (    ), hidden under the Spot Healing Brush tool ( ). 

8 In the options bar, reduce the Pupil Size to 23% and the Darken Amount to 62%. 

The Darken Amount specifies how dark the pupil should be. 

9 Click the pupil in the woman’s left eye. The red reflection disappears. 

10 Click the pupil in the woman’s right eye to remove the red reflection there, too. 
 

 

 

If the red reflection is directly over the pupil, clicking the pupil removes it. How- 
ever, if the red reflection is slightly off the pupil, try clicking the highlight in the eye 
first. You may need to try a few different spots, but it’s easy to undo and try again. 
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11 Choose View > Fit On Screen to see the entire image. 
 

 

12 Choose File > Save. 
 

Brightening an image 
The woman’s eyes no longer glow red, but the overall image is a bit dark. You can 
brighten an image in several different ways, as you’ve already seen. You can try 
adding adjustment layers for Brightness/Contrast, Levels, and Curves, depending 
on the degree of adjustment you want to make. For a quick fix or a good starting 
point, try the Auto button or the presets, which are available in both the Levels 
and Curves adjustments. Let’s try a Curves adjustment layer for this image. 

1 Click Curves in the Adjustments panel. 

2 Click Auto to apply an automatic correction. The image brightens. 
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3 Choose Lighter from the Preset menu. The curve changes slightly. The difference 
between the two curves is that a preset applies the same curve to every image, 
while Auto customizes the curve after analyzing an individual image. 

 

 

4 Click the reset button ( ) at the bottom of the Properties panel to revert back to 
the unadjusted image. 

5 Select the on-image adjustment tool ( ) in the Curves panel, and then click the 
center of the forehead and drag upwards. That brightens the image nicely, and 
also improves the contrast. 

 
 
 

E Tip: If you want to 
use the Auto button, 
or the white point or 
black point samplers 
(eyedropper icons) in 
the Curves or Levels 
adjustments, use them 
before applying manual 
adjustments. Like 
presets, adjustments 
by those tools replace 
manual adjustments. 

 
 
 
 

 
 
 
 

6 Choose Layer > Flatten Image. 

7 Save the file. 

 
E Tip:  To see how 
much you’ve brightened 
the image, hide the 
Curves layer, and then 
show it again. 
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Adjusting facial features with Liquify 
The Liquify filter is useful when you want to distort only part of an image. It 
includes Face-Aware Liquify options that can automatically recognize faces in 
images, and then lets you easily adjust facial features such as the eyes, nose, and 
mouth. For example, you can adjust the size of or distance between the eyes. 
Being able to adjust facial features can be useful for photos used in advertising and 
fashion, when portraying a certain look or expression may be more important than 
faithfully representing a specific person. 

1 With RedEye_Working.psd still open, choose Filter >   Liquify. 

2 In the Properties panel, expand the Face-Aware Liquify options. 
 

 
E Tip: When the Face tool ( ) is selected in the Liquify toolbar, handles appear as you hover the 
pointer over different parts of the face. You can drag those handles to adjust different parts of the 
face directly, as an alternative to dragging the Face-Aware Liquify sliders. 
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3 Make sure the Eyes section is expanded and that the link icon is selected for 
both Eye Size and Eye Height; then enter 32 for Size and 10 for Height. 

When the link icon is not selected for an Eyes option, you can set different values 
for the left and right eyes. 

4 Make sure the Mouth section is expanded, and then enter 5 for Smile and 9 for 
Mouth Height. 

5 Make sure the Face Shape section is expanded, and then enter 40 for Jawline 
and 50 for Face Width. 

6 Deselect and reselect the Preview option to compare the image before and 
after your changes. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
E Tip: The Face-Aware 
Liquify options have a 
limited range because 
they’re designed for 
subtle, believable 
distortions. If you want 
to exaggerate faces into 
caricatures or extreme 
expressions, you may 
want to use the more 
advanced manual tools 
along the left side of the 
LIquify dialog box. 

 
 
 
 

Before Face-Aware Liquify After Face-Aware Liquify 

Feel free to experiment with any of the Face-Aware Liquify options to get a better 
sense of the possibilities for quick, easy alterations. 

7 Click OK to exit Liquify. Close the document and save your    changes. 

The Face-Aware Liquify features are available only when Photoshop recognizes a 
face in an image. It may not recognize a face that is turned too far away from the 
camera or when a face is partially covered by hair, sunglasses, or a hat shadow. 
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Blurring a background 
The interactive blurs in the Blur Gallery let you customize a blur as you preview it 
on your image. You’ll use an iris blur to blur the background in an image, focusing 
the viewer’s attention on the main attraction—in this case, the egret. You’ll apply 
the blur as a Smart Filter so that you can modify it later if you want to. 

You’ll start by looking at the start and end files in   Bridge. 

1 Choose File > Browse In Bridge to open Adobe Bridge. 

2 In the Favorites panel in Bridge, click the Lessons folder. Then, in the Content 
panel, double-click the Lesson05 folder to open it. 

3 Compare the Egret_Start.jpg and Egret_End.psd thumbnail previews. 
 

Egret_Start.jpg Egret_End.psd 

In the final image, the egret appears sharper, as its reflection and the grass around 
it have been blurred. Iris Blur, one of the interactive blurs in the Blur Gallery, makes 
the task an easy one—no masking required. 

4 Return to Photoshop, and choose File > Open As Smart Object. 

5 Select the Egret_Start.jpg file in the Lesson05 folder, and click OK or Open. 
 

 

Photoshop opens the image. There is one layer in the Layers panel, and it’s 
a Smart Object, as indicated by the badge on the layer thumbnail icon. 

6 Choose File > Save As, choose Photoshop for the Format, name the file 
Egret_Working.psd, and click Save. Click OK in the Photoshop Format 
Options  dialog box. 
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7 Choose Filter > Blur Gallery > Iris  Blur. 

A blur ellipse is centered on your image. You can adjust the location and scope of the 
blur by moving the center pin, feather handles, and ellipse handles. At the top right 
corner of the Blur Gallery task space, you also see the expandable Field Blur, Tilt-Shift 
Blur, Path Blur, and Spin Blur panels. 

8 Drag the center pin so that it’s at the bottom of the bird’s body. 

9 Click the ellipse, and drag inward to tighten the focus around the bird. 

A B C D 

 
 
E Tip: If you have an 
iPhone camera that 
produces an HEIF depth 
map, such as an iPhone 
Plus or iPhone X, you 
can create a more 
realistic background 
blur effect by loading 
the depth map into the 
Lens Blur filter (Filter > 
Blur > Lens Blur). This 
requires a Mac using 
macOS 10.13 or later. 

 
 
 
 
 

A. Center  B. Ellipse  C. Feather handle  D.  Focus 

10 Press Alt (Windows) or Option (Mac) as you click and drag the feather handles 
to match those in the first image below. Pressing Alt or Option lets you drag 
each handle separately. 

11 Click and drag on the focus ring to reduce the amount of blur to 5 px, creating 
a gradual but noticeable blur. You can also change the amount of blur by moving 
the Blur slider in the Iris Blur area of the Blur Tools panel. 

 

 

12 Click OK in the options bar to apply the blur. 

The blur may be a little too subtle. You’ll edit the blur to increase it slightly. 

13 Double-click the Blur Gallery in the Egret layer in the Layers panel to open 
it again. Adjust the blur to 6 px, and click OK in the options bar to apply it. 

The egret is accentuated by blurring the rest of the image. Because you applied 
the filter to a Smart Object, you can hide or edit the effect without altering the 
original image. 

14 Save the file, and then close it. 
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Blur Gallery 
The Blur Gallery includes five interactive blurs: Field Blur, Iris Blur, Tilt-Shift, Path Blur, and Spin Blur. Each gives 
you on-image selective motion blur tools, with an initial blur pin. You can create additional blur pins by clicking 
on the image. You can apply a single blur or a combination of blurs, and you can create a strobe effect for path 
and spin blurs. 

 
 
 
 
 
 
 
 
 

Before After Before After 

Field Blur applies a gradient blur to areas of the 
image, defined by pins you create and settings 
you specify for each. When you first apply Field 
Blur, a pin is placed in the center of the image. 
You can adjust the blur relative to that point by 
dragging the blur handle or specifying a value in 
the Blur Tools panel; you can also drag the pin to 
a different location. 

Iris Blur simulates a shallow depth-of-field effect, 
gradually blurring everything outside the focus ring. 
Adjust the ellipse handles, feather handles, and blur 
amount to customize the iris blur. 

 
 
 
 
 
 
 
 
 

Before 
 

After 
 

Before 
 

After 

Tilt-Shift simulates an image taken with a tilt-shift 
lens. This blur defines areas of sharpness and then 
fades to a blur at the edges. You can use this effect 
to simulate photos of miniature objects. 

Spin Blur is a radial-style blur measured in degrees. 
You can change the size and shape of the ellipse, 
re-center the rotation point by pressing Alt or 
Option as you click and drag, and adjust the blur 
angle. You can also specify the blur angle in the Blur 
Tools panel. Multiple spin blurs can overlap. 
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Before After Before After 

Path Blur creates motion blurs along paths you 
draw. You control the shape and amount of 
the blur. 

When you first apply a Path Blur, a default path 
appears. Drag the end point to reposition it. Click 
the center point and drag to change the curve. 
Click to add additional curve points. The arrow on 
the path indicates the blur’s direction. 

You can also create a multiple-point path or a shape. 
Blur shapes describe the local motion blurs, similar 
to camera shake (see “Camera Shake Reduction” on 
page 138). The Speed slider in the Blur Tools panel 
determines the speed for all the path blurs. The 
Centered Blur option ensures that the blur shape for 
any pixel is centered on that pixel, resulting in more 
stable-feeling motion blurs; to make the motion 

You can add a strobe effect to spin and path blurs. 
Select the Motion Effects tab to bring its panel 
forward. The Strobe Strength slider determines how 
much blur shows between flash exposures (0% 
gives no strobe effect; 100% gives full strobe effect 
with little blur between exposures). Strobe Flashes 
determines the number of exposures. 

appear more fluid, deselect this option. Before After 

In the Effects tab, you specify the bokeh parameters 
to control the appearance of blurred areas. Light 
Bokeh brightens the blurred areas; Bokeh Color 
adds more vivid colors to lightened areas that aren’t 
blown out to white; Light Range determines the 
range of tones that the settings affect. 

Applying a blur will smooth out visible digital image 
noise or film grain that’s in the original image, and 
this mismatch between the original and blurred 
areas can make the blur appear artificial. You can 
use the Noise tab to restore noise or grain so that 
blurred areas match up with unblurred areas. Start 
with the Amount slider, and then use the other 
Noise options to match the character of the original 
grain. Increase the Color value if the original has 
visible color noise, and lower the Highlights value if 
you need to balance the noise level in the highlights 
compared to the shadows. 
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Creating a panorama 
Sometimes a vista is just too large for a single shot. Photoshop makes it easy to com- 
bine multiple images into a panorama so that your viewers can get the full effect. 

Once again, you’ll take a look at the end file first, to see where you’re going. 

1 Choose File > Browse In Bridge. 

2 Navigate to the Lesson05 folder, if you’re not there already. Then, look at the 
Skyline_End.psd  thumbnail preview. 

 

 
 
 
 
 
 
 
E Tip: You can also 
open selected images 
from Bridge directly into 
Photomerge by choos- 
ing Tools > Photoshop > 
Photomerge. 

Skyline_End.psd 

You’ll combine four shots of the Seattle skyline into a single wide panorama image 
so that viewers get a sense of the whole scene. Creating a panorama from multiple 
images requires only a few clicks. Photoshop does the rest. 

3 Return to Photoshop. 

4 With no files open in Photoshop, choose File > Automate > Photomerge. 

5 In the Source Files area, click Browse, and navigate to the Lesson05/Files For 
Panorama folder. 

6 Shift-select all the images in the folder, and click OK or Open. 

7 In the Layout area of the Photomerge dialog box, select Perspective. 

The best option for merging photos isn’t always Perspective; it depends on how the 
originals were photographed. If you’re not completely happy with the result of a 
particular merge, you can always try again with a different Layout option. If you’re 
not sure which one to use, you can simply click Auto. 

8 At the bottom of the Photomerge dialog box, select Blend Images Together, 
Vignette Removal, Geometric Distortion Correction, and Content Aware Fill 
Transparent Areas. Then click OK. 
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Blend Images Together blends images based on the optimal borders between them, 
instead of just creating a simple rectangular blend. Vignette Removal performs 
exposure compensation in images with darkened edges. Geometric Distortion 
Correction compensates for barrel, pincushion, or fisheye distortion. Content 
Aware Fill Transparent Areas automatically patches the empty areas between the 
merged image edges and the sides of the canvas. 

Photoshop creates the panorama image. It’s a complex process, so you may have 
to wait a few moments while Photoshop works. When it’s finished, you’ll see the 
full vista in the image window with five layers in the Layers panel. The bottom four 
layers are the original four images you selected. Photoshop identified the overlap- 
ping areas of the images and matched them, correcting any angular discrepancies. 
The top layer, containing “(merged)” in the layer name, is a single panorama image 
blended from all of the images you selected, combined with formerly empty areas 
filled in by Content Aware Fill. Those areas are indicated by the selection. 

 
 
 
 
 
 
 
 

● Note: Photomerge 
will require more time 
when you merge more 
images, or images with 
large pixel dimensions. 
Photomerge works 
faster on computers 
that are newer or that 
have more RAM. 

 
 
 

E Tip: If you want to 
see how the panorama 
looks without the areas 
created by Content 
Aware Fill, hide the 
top layer. 
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9 Choose Select >  Deselect. 

10 Choose Layer > Flatten Image. 
 

 

11 Choose File > Save As. Choose Photoshop for the Format, and name the file 
Skyline_Working.psd. Save the file in the Lesson05 folder. Click Save. 

The panorama looks great, but it’s a little dark. You’ll add a Levels adjustment layer 
to brighten it a little bit. 
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Getting the best results 
with Photomerge 
If you know you’re going to create a panorama when you take your shots, keep the 
following guidelines in mind to get the best result. 

Overlap images approximately 40%. You want enough overlap that Photomerge 
can assemble the panorama but not so much that it can’t blend the images. 

Use a consistent focal length. If you use a zoom lens, keep the focal length the 
same for all the pictures in the panorama. 

Use a tripod if possible. You’ll get the best results if the camera is at the same level 
when you take each of the shots. A tripod with a rotating head makes that easier. 

Take the photos from the same position. If you’re not using a tripod with a rotat- 
ing head, try to stay in the same position as you take the photos, so that they are 
taken from the same viewpoint. 

Avoid distortion lenses. They can interfere with Photomerge. (The Auto option 
does adjust for images you take with fisheye lenses, though.) 

Use the same exposure. The images will blend more gracefully if they all have the 
same exposure. For example, either use flash for all the images or for none of them. 

Try different layout options. If you don’t like the results you get when you 
create the panorama, try again using a different layout option. Often, Auto selects 
the appropriate option, but sometimes you’ll get a better image with one of the 
other options. 
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12 Click the Levels icon in the Adjustments panel to add a Levels adjustment layer. 

13 Select the White Point eyedropper in the Properties panel, and then click on a 
white area of the clouds. 

 

 

 

 

The sky gets bluer, and the entire image brightens. 

14 Save your work. Click OK in the Photoshop Format Options dialog box. 

It’s that easy to create a panorama! 

 
 
● Note: In this case, 
the Photoshop Format 
Options alert may 
appear because a 
layer was added. The 
Photoshop Format 
Options dialog box 
usually won’t appear for 
Photoshop documents 
containing only a 
Background layer. 
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Filling empty areas when cropping 
The panorama image looks great except for two things: The horizon is slightly 
tilted, and the lower handrail is incomplete where the rocks on the right descend 
into the water. If you were to rotate the image, empty areas might appear at the cor- 
ners, requiring a tighter crop and losing parts of the image. Fortunately, the same 
Content-Aware technology that filled in empty areas resulting from the panorama 
merge can also fill in empty areas that can result from straightening and cropping. 

1 Make sure Skyline_Working.psd is open, and make sure the Background layer 
is selected in the Layers  panel. 

2 Choose Layer > Flatten Image. 

3 In the Tools panel, select the Crop tool. The crop rectangle and its handles 
appear around the image. 

 

 

4 In the options bar, select the Straighten button ( ), and make sure Content- 
Aware is selected. 

 

 

5 Position the Straighten pointer on the horizon at the left edge of the image, 
and drag to the right to create a Straighten line that’s aligned with the horizon; 
release the mouse button when you reach the end of the horizon at the right 
edge of the image. 
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Notice there is now white space that needs to be filled near the corners. 
 

   

   

   

 
6 With the crop rectangle still active, drag the image down until the incomplete 

part of the lower guardrail is outside the crop rectangle. 
 

   

   

   

 
7 Click the Commit button in the options bar ( ) to apply the current crop 

settings. Content-Aware Crop fills in the empty areas at the top and sides of 
the image. 

 

 

8 Save your changes, and close the document. 
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Correcting image distortion 
The Lens Correction filter fixes common camera lens flaws, such as barrel and 
pincushion distortion, chromatic aberration, and vignetting. Barrel distortion is  
a lens defect that causes straight lines to bow out toward the edges of the image. 
Pincushion distortion is the opposite effect, causing straight lines to bend inward. 
Chromatic aberration appears as a color fringe along the edges of image objects. 
Vignetting occurs when the edges of an image, especially the corners, are darker 
than the center. 

Some lenses exhibit these defects depending on the focal length or the f-stop used. 
The Lens Correction filter can apply settings based on the camera, lens, and focal 
length that were used to make the image. The filter can also rotate an image or fix 
image perspective caused by tilting a camera vertically or horizontally. The filter’s 
image grid makes it easier and more accurate to make these adjustments than using 
the Transform command. 

1 Choose File > Browse In Bridge. 

2 Navigate to the Lesson05 folder if you’re not already there, and then look at the 
Columns_Start.psd and Columns_End.psd thumbnail previews. 

 

  
 
 
 
 
 
 
E Tip: If the crop 
rectangle from the 
previous exercise is still 
visible and distracting, 
switch to a tool such as 
the Hand tool. 

Columns_Start.psd Columns_End.psd 

In this case, the original image of a Greek temple is distorted, with the columns 
appearing to be bowed. This photo was shot at a range that was too close with a 
wide-angle lens. You’ll quickly correct the lens barrel distortion. 

3 Double-click the Columns_Start.psd file to open it in Photoshop. 

4 Choose File > Save As. In the Save As dialog box, name the file Columns_ 
Working.psd, and save it in the Lesson05 folder. Click OK if the Photoshop 
Format  Options  dialog  box appears. 
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5 Choose Filter > Lens Correction. The Lens Correction dialog box opens. 

6 Select Show Grid at the bottom of the dialog box, if it’s not already selected. 

An alignment grid overlays the image. To the right are options for automatic 
corrections based on lens profiles. In the Custom tab are manual controls for cor- 
recting distortion, chromatic aberration, and perspective. 

 

The Lens Correction dialog box includes auto-correction options. You’ll adjust one 
setting in the Auto Correction tab and then customize the settings. 

7 In the Correction area of the Auto Correction tab, make sure Auto Scale Image 
is selected, and that Transparency is selected from the Edge menu. 

8 Select the Custom tab. 

9 In the Custom tab, drag the Remove Distortion slider to about +52.00 to 
remove the barrel distortion in the image. Alternatively, you could select the 
Remove Distortion tool ( ) and drag in the image preview area until the 
columns are straight. The adjustment causes the image borders to bow inward. 
However, because you selected Auto Scale Image, the Lens Correction filter 
automatically scales the image to adjust the borders. 

 
 
 
 
 
 
 
 
E Tip: Watch the 
alignment grid as you 
make these changes so 
that you can see when 
the vertical columns 
are straightened in 
the image. 
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10 Click OK to apply your changes and close the Lens Correction dialog box. 
 

The curving distortion caused by the wide-angle lens and low shooting angle 
is eliminated. 

11 (Optional) To see the effect of your change in the main image window, press 
Ctrl+Z (Windows) or Command+Z (Mac) twice to undo and redo the filter. 

12 Choose File > Save to save your changes, click OK if the Photoshop Format 
Options dialog box appears, and then close the image. 

 

The temple looks much more stable now! 
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Extending depth of field 
When you’re shooting a photo, you often have to choose to focus either the 
background or the foreground. If you want the entire image to be in focus, you can 
take two photos—one with the background in focus and one with the foreground in 
focus—and then merge the two in Photoshop. 

Because you’ll need to align the images exactly, it’s helpful to use a tripod to keep the 
camera steady. Even with a handheld camera, though, you can get some amazing 
results. In this exercise, you’ll add depth of field to an image of a wine glass in front 
of a beach. 

1 Choose File > Browse In Bridge. 

2 Navigate to the Lesson05 folder, if you’re not there already, and then look at the 
Glass_Start.psd and Glass_End.psd thumbnail previews. 

 

Glass_Start.psd Glass_End.psd 

The first image has two layers. Depending on which layer is visible, either the glass 
in the foreground or the beach in the background is in focus. You’ll extend the 
depth of field to make both clear. 

3 Double-click the Glass_Start.psd file to open it. 

4 Choose File > Save As. Name the file Glass_Working.psd, and save it in the 
Lesson05 folder. Click OK if the Photoshop Format Options dialog box appears. 
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5 In the Layers panel, hide the Beach layer, so that only the Glass layer is visible. 
The glass is in focus, but the background is blurred. Then, show the Beach layer 
again. Now the beach is in focus, but the glass is blurred. 

 
 
 
 
 

 
 
 
 
 

You’ll merge the layers, using the part of each layer that is in focus. First, you need 
to align the layers. 

6 Shift-click to select both of the layers. 
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7 Choose Edit > Auto-Align  Layers. 

Because these images were shot from the same angle, Auto will work just fine. 

8 Select Auto, if it isn’t already selected. Make sure neither Vignette Removal 
nor Geometric Distortion is selected. Then click OK to align the layers. 

 
 
 
 

E Tip: When aligning 
layers that are not 
involved in a panorama, 
Reposition is often the 
best alignment option 
to use. In this exercise, 
Reposition is the 
projection that the Auto 
option chose. 

 
 
 
 
 
 
 

Now that the layers are perfectly aligned, you’re ready to blend them. 

9 Make sure both layers are still selected in the Layers panel. Then choose 
Edit > Auto-Blend Layers. 

10 Select Stack Images and Seamless Tones And Colors, if they aren’t already 
selected. Make sure Content Aware Fill Transparent Areas is not selected, 
and then click OK. 

 

11 Save your work, and close the  file. 

Both the wine glass and the beach behind it are in focus. 

 
 
 
 
 

E Tip:  The technique 
in this exercise, called 
focus stacking, is useful 
for macro photography, 
where depth of field is 
typically very shallow. 
Multiple images with 
shallow depth of field 
are shot at different 
focus distances, and 
then merged. 
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Moving objects with the 
Content-Aware Move tool 
You’ve used the content-aware features in some pretty impressive ways in earlier 
lessons, and to fill in the sky in the panorama project in this lesson. Now you’ll use 
the Content-Aware Move tool to move something in an image (in this case, a duck) 
and have Photoshop convincingly fill in the area where the item you moved used to 
be. You can also use the Content-Aware Move tool to extend a portion of an image, 
such as a stand of trees or fence posts, seamlessly. 

1 Choose File > Browse In Bridge. 

2 Navigate to the Lesson05 folder, if you’re not there already, and then look at the 
Ducks_Start.jpg and Ducks_End.psd thumbnail previews. 

 

  
 
 
 
 
 
 
 
 
 

E Tip: If you have 
trouble finding the 
Content-Aware Move 
tool, click the Search 
icon ) at the top right 
corner of the Photoshop 
application window, 
and enter the name of 
the tool. 

Ducks_Start.jpg Ducks_End.psd 

You’ll use the Content-Aware Move tool to nudge the last duck into a cluster with 
its companions. 

3 Double-click the Ducks_Start.jpg file to open it in Photoshop. 

4 Choose File > Save As, choose Photoshop for the format type, and name the 
new file Ducks_Working.psd. Click Save. 

5 Select the Content-Aware Move tool ( ), which is grouped with the Red Eye 
Removal tool (    ) and may be hidden under it. 

6 In the options bar, choose Move from the Mode menu, and enter 3 in the 
Structure field. 

 

 

 
 
 
 
 
 
 
 

130    LESSON 5    Quick Fixes 



From the Library of Alvaro Alvarez  

 
 

7 Draw a selection marquee around the third duck, with a margin large enough to 
include the grass and dirt around it. 

8 Drag the selection to the left, slightly above the second duck, so that the ducks 
are clustered. 

 

When you release the mouse, the dragged duck appears with a transformation rect- 
angle and handles. These transformation controls give you an opportunity to rotate 
and scale the content, but you don’t need to do that in this step. 

9 Click the Commit Transform button (   ) in the options bar. 
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More on the 
Content-Aware Move tool 
The Content-Aware Move tool is very impressive when you’re working with   
some images, and less impressive with others. For best results, use it when the 
background is consistent enough that Photoshop will be able to recognize and 
replicate a pattern. In the image of ducks, the grass and dirt are fairly consistent 
and repetitive. You can also try moving objects with backgrounds such as meadows, 
solid-colored walls, sky, wood grains, or water. 

The Extend mode of the Content-Aware tool can be useful with architectural sub- 
jects, especially when they’re shot on a plane parallel to the camera; it’s less effective 
for subjects shot at an angle. 

If you’re working with an image that has multiple layers, select Sample All Layers in 
the options bar to include them all in the selection. 

The Structure and Color options define how closely the results reflect the existing 
image patterns. In the Structure settings, 1 is the loosest and 5 the strictest. The 
Color settings range from 0 (no color adaptation) to 10 (matching the color as 
closely as possible). Experiment with the options while the object is still selected 
to see which give you the best results in a particular image. You may want to hide 
the selection edges (choose View > Show > Selection Edges or View > Extras) to see 
how the object integrates into its new position. 
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10 Change the Structure setting to 5, which requires stricter adherence to the 
pattern, and observe how the image changes. Then change the Structure setting 
to 1, which results in a much looser adaptation. You can also experiment with 
different Color settings, from 0 to 10. 

Now that you’ve committed to the move, Photoshop fills in the area the duck left 
behind. How it creates the area depends on the Structure and Color settings in the 
options bar. You can try different options while the selection remains active. 

11 Choose the Structure and Color options you think look best. Then choose 
Select > Deselect. 

The three ducks are in a tighter formation now, and you can’t tell that the third 
duck used to be in a different position. 

 

12 Save your work, and close the  file. 
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Extra credit 

Transformations with the Content-Aware Move tool 

With the Content-Aware Move tool, you need only a few quick steps to duplicate a thistle so that it 
combines seamlessly with the background, and is also different enough that it doesn’t look like an 
exact copy of the original. 

1 Open Thistle.psd in your Lesson05/Extra Credit folder. 

2 Select the Content-Aware Move tool (    ), which is grouped with the healing brush tools. 

3 In the options bar, choose Extend from the Mode menu. Choosing Extend duplicates the thistle; 
if you just want to reposition the single thistle, you would choose Move. 

 
 

4 With the Content-Aware Move tool, draw a selection marquee around the thistle, with a margin 
large enough to include a little of the grass around it. 

5 Drag the selection to the left, and drop it in the empty area of grass. 

6 Right-click (Windows) or Control-click (Mac) the dragged thistle, and choose Flip Horizontal. 

7 Drag the top left transformation handle to make the thistle smaller. If you think the copy of the 
thistle should be farther from the original, position the pointer inside the transformation rectangle 
(but not over the anchor point) and drag the thistle copy slightly to the left. 

8 Press Enter or Return to make the transformations permanent, leaving the content selected so 
you can adjust the Structure and Color options to improve how the new thistle blends with the 
background. 

9 Choose Select > Deselect, and save your changes. 
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Adjusting perspective in an image 
The Perspective Warp feature lets you adjust the way objects in your image relate 
to the scene. You can correct distortions, change the angle from which an object 
appears to be viewed, or shift the perspective of an object so that it merges 
smoothly with a new background. 

Using the Perspective Warp feature is a two-step process: defining the planes and 
adjusting them. You start in Layout mode, drawing quads to define two or more 
planes; it’s a good idea to align the edges of the quads so that they are parallel with 
the lines of the original object. Then you switch to Warp mode, and manipulate the 
planes you defined. 

You’ll use Perspective Warp to merge images with different perspectives. 

1 Choose File > Browse In Bridge. 

2 Navigate to the Lesson05 folder, if you’re not there already, and then look 
at the Bridge_Start.psd and Bridge_End.psd thumbnail previews. 

 

Bridge_Start.psd Bridge_End.psd 

In the Bridge_Start.psd file, the image of the train has been combined with the 
image of a trestle bridge, but their perspectives don’t match. If you’re illustrating 
a story about a flying train that is making a landing on a trestle bridge, this might 
be perfect. But if you want a more realistic image, you’ll need to adjust the perspective 
of the train to put it firmly on the tracks. You’ll use Perspective Warp to do just that. 

3 Double-click the Bridge_Start.psd file to open it in Photoshop 

4 Choose File > Save As, and rename the file Bridge_Working.psd. Click OK in 
the Photoshop Format Options dialog    box. 
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5 Select the Train layer. 
 

 

The tracks are on the Background layer. The train is on the Train layer. Because the 
Train layer is a Smart Object, you can apply Perspective Warp and then modify the 
results if you’re not satisfied. 

6 Choose Edit > Perspective Warp. This feature requires a fair amount of 
processing power. If Perspective Warp is grayed out when you try to select it, 
make sure you have a current video card and a minimum of 512 MB VRAM. 

A small animated tutorial appears, showing you how to draw a quad, which defines 
a plane. 

7 Watch the animation, and then close it. 

Now you’ll create quads to define the planes of the train image. 

8 Draw the quad for the side of the train: Click above the top of the smokestack, 
drag down to the railroad tie below the front wheel, and then drag across to the 
end of the caboose. The plane is currently a rectangle. 

9 Drag a second quad for the front of the train, dragging across the cowcatcher 
at the bottom and into the trees at the top. Drag it to the right until it attaches 
to the left edge of the first quad. 

10 Drag the corners of the planes to match the angles of the train. The bottom line 
of the side plane should run along the bottom of the train wheels; the top edge 
should border the top of the caboose. The front plane should mirror the lines 
of the cowcatcher and the top of the light. 
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Now that the quads are drawn, you’re ready for the second step in the process: 
warping. 

11 Click Warp in the options bar. Close the tutorial box that shows you how to warp 
the plane. 

12 Click the Automatically Straighten Near Vertical Lines button, next to Warp in 
the options bar. 

 

 

This makes the train appear properly vertical, making it easier to adjust the perspective 
accurately. 

13 Drag the handles to manipulate the planes, moving the back end of the train 
down and into perspective with the tracks. Exaggerate the perspective toward 
the caboose for a more dramatic result. 

14 Warp other parts of the train as needed. You may need to adjust the front of the 
train. Pay attention to the wheels; make sure you don’t distort them as you warp 
the perspective. 

 

 

While there are precise ways to adjust perspective, in many cases you may need to 
trust your eyes to tell you when it looks right. Remember you can return to tweak it 
again later, because you’re applying Perspective Warp as a Smart Filter. 

15 When you’re satisfied with the perspective, click the Commit Perspective Warp 
button (    ) in the options bar. 

16 To compare the changed image with the original, hide the Perspective Warp filter 
in the Layers panel. Then show the filter again. 

If you want to make further adjustments, double-click the Perspective Warp 
filter in the Layers panel. You can continue to adjust the existing planes, or click 
Layout in the options bar to reshape them. Remember to click the Commit 
Perspective Warp button to apply your changes. 

17 Save your work, and close the  file. 
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Changing the perspective 
of a building 
In the exercise, you applied Perspective Warp to one layer to change its relationship 
with another. But you can also use Perspective Warp to change the perspective of 
an object in relationship to others in the same layer. For example, you can shift the 
angle from which you view a building. 

In this case, you apply Perspective Warp the same way: In Layout mode, draw the 
planes of the object you want to affect. In Warp mode, manipulate those planes. Of 
course, because you’re shifting angles within a layer, other objects on the layer will 
move, too, so you need to watch for any irregularities. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In this image, as the perspective of the building shifted, 
so did the perspective of the trees surrounding it. 
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Camera Shake Reduction 
Even with a steady hand, unintended camera motion can occur with slow shutter 
speeds or long focal lengths. The Camera Shake Reduction filter reduces the result- 
ing camera shake, giving you a sharper image. 

 
 
 
 
 
 
 
 
 
 
 

Before applying the Camera Shake Reduction filter 

You’ll get the best results if you apply the filter to a particular part of an image, 
rather than the entire image. It can be especially useful if text has become illegible 
due to camera shake. 

To use the Camera Shake Reduction filter, open the image, and choose Filter > 
Sharpen > Shake Reduction. The filter automatically analyzes the image, selects 
a region of interest, and corrects the blur. Use the Detail loupe to examine the 
preview. That may be all you need to do. If so, click OK to close the Shake Reduction 
dialog box and apply the filter. 

 
 
 
 
 
 
 
 
 
 
 

After applying the Camera Shake Reduction filter 

You can adjust how Photoshop interprets the Blur Trace, which is the shape and 
size of the camera shake that Photoshop identified. You can change the region 
of interest or adjust its size, adjust the Smoothing and Artifact Suppression 
values, and more. For full information about the Camera Shake Reduction filter, 
see Photoshop Help. 


